Hardware => Lynx Freestyle => Topic started by: aERonAUtical96 on December 10, 2013,

Title: FS channels not working
Post by: aERonAUtical96 on December 10, 2013,
I have random channels that do not appear to be working (~20  don't have my notes with me).  They are random, i.e no particular order.  I've moved the flip-flop chips around thinking maybe problem follows, but it does not.  I've had the FS for about 4 years now.  There were a couple of channels in previous years that stopped working and are a part of the list that aren't working this year.  Seems like more channels continue to stop working.

SSR4s work as I can move them around to good channels.  Tried different cables as well.

So my question...

What can be investigated as the issue?  Couple of things that I can think of...
1. Reflash PIC... a little hesitant to do that now... show running with channels that work.  Don't want to mess with it.
2. Resolder those channels on the RJ45 connector side.  Then follow back to the socket chip holders and hit those joints.
3. 485 chip?  I have one from a SSR DMX kit that I haven't assembled that I could put in.

Anything else?
Title: Re: FS channels not working
Post by: tbone321 on December 10, 2013,
If it were th3 485, then none of the channels would be working.  It could be a failing PIC. 
Title: Re: FS channels not working
Post by: aERonAUtical96 on November 20, 2016,
I'm reactivating this thread.  I've replaced the PIC and get the same result.  Here is an interesting tidbit... I've switched to xLights and am using the Test tool functionality.  When I attempt to turn on a channel that I knew was not lighting up the past, it behaves exactly the same (no light).  However, if I select all models (created models 1-128) and turn background to full 255, I get lights on the channels that do not work when called individually.  I'm not sure if this is correct behavior from the tool.

Any ideas/suggestions.
Title: Re: FS channels not working
Post by: chrisatpsu on November 21, 2016,
Do you have another FS?

Have you tried retouched the solder points on the sockets that hold the flip flops?

make sure the chips don't have bent or corroded pins?

It looks like the channel information goes from the PIC directly to the flip flops, and then to the sockets. with no other parts in between.

check over your rj45 jacks to make sure nothing shorted, or burnt, or corroded. check their solder joints.

If it's happening to particular channels, are they bunched together? (check more towards flip flops), or all across the board (rj45 connectors)
Title: Re: FS channels not working
Post by: aERonAUtical96 on November 29, 2016,
I don't have another FS.  I hit all of the joints again.  No change.   I've swapped flip flops hoping problem follows.  Does not follow the flip flop.  I've replaced just about everything I have a spare of (all the chips and even the XTAL clock. The only thing I haven't tried is to replace the Rj45 jack. 

I'm trying to reduce my need on the FS so I have enough working ports for the limited number of SSR4s that I use now.  At some point in time I would like to pass the FS and SSR4s onto the next person who is getting into the hobby, but would like for the board to fully work.

Thanks for reading and suggestions.
Title: Re: FS channels not working
Post by: WWNF911 on December 08, 2016,
I saw this last night and thought of this problem. I work in the medical field and see this a lot.

The thread where I found it is here:
Title: Re: FS channels not working
Post by: caretaker on December 09, 2016,
Try testing with RJ's DMX deck;topic=2742.0;attach=2704  and see if that causes the channel to work. If it does than the problem is in the Xlights setup. If not futher exploration is needed.
Title: Re: FS channels not working
Post by: aERonAUtical96 on December 10, 2016,
I'm starting to lean towards the RJ45 jack.  I have not looked into the jacks deeply as the FS is out in the yard currently.  When I bust down the display this year I will focus on the RJ45.  I was even thinking of replacing a jack as a test.  But to desolder those things... ugggh.

It isn't an xLights specific problem.  I have had the problem with xLights, FPP and even Vixen 2.1 and 2.5.  Same channels are out.  It isn't a software configuration issue.  It appears to be hardware.