Author Topic: Firmware version  (Read 739 times)

Offline onetmat

  • Jr. Member
  • **
  • Posts: 7
Firmware version
« on: January 19, 2015, »
I purchased a v1.2 wireless from the sale page and don't know what firmware version is on it. It will be used with v2 so I want to make sure they will work together. I do not have a pickit, so is there a way to find out what it has? Are there any other things I should know about using the v1.2 wireless with newer versions.
Thanks
Mat

Offline tbone321

  • Sr. Member
  • ****
  • Posts: 3984
Re: Firmware version
« Reply #1 on: January 19, 2015, »
In order for it to work with Ver2 equipment, it will need the VER2 compatible firmware.  This firmware is available in the WIKI in the outdated equipment section.  There is no way to know what version is on it or be able to update it without either a Pickit-2 or Pickit-3.  The simple fact is that one of these programmers really is a required piece of equipment for this hobby when using PIC based equipment so I would look into getting one of these ASAP.  While the Pickit-2 is much easier to use, it is outdated and will not program the 32bit and higher PIC's so you will probably need the Pickit-3 anyway so you should probably get that one. 
If at first you don't succeed,
your not cut out for sky diving

Offline egenoup

  • Sr. Member
  • ****
  • Posts: 359
Re: Firmware version
« Reply #2 on: January 20, 2015, »
Onemat,

If it is the wireless TX/RX and Ex/RX that you bought from me, then they have the most current firmware available at the time I tested the Lynx equipment for you.  The tests where performed using your equipment and one of my DMX dongles. If you have any questions regarding the equipment I sold you, please PM me.

Thanks,

Charles

Offline onetmat

  • Jr. Member
  • **
  • Posts: 7
Re: Firmware version
« Reply #3 on: January 20, 2015, »
egenoup
Its not yours since yours are the version 2 I'm making sure this other one works with. You told me about your items and they should be just fine. The seller of the version 1.2 wasn't sure what firmware was install which was fine.

I figured I would need a pickit to test it but I haven't yet messed with the wireless  to see how they work together. I will probably contact one of the members who will program one for me in a month or so if needed.

Offline egenoup

  • Sr. Member
  • ****
  • Posts: 359
Re: Firmware version
« Reply #4 on: January 20, 2015, »
Perfect... If you need help, just let me know.  I can also program them for you if you need them, but you would have to ship them back and forth.  It's better (and way less money) to find someone within driving distance.

Charles