Author Topic: DMX Dongle V2.0 and LE Config Utility Install Issues  (Read 403 times)

Offline kidcole

  • Full Member
  • ***
  • Posts: 71
  • Light Crazy Since 2009
Hi ..  I appreciate all the help here.  I am a novice with LE controllers.  I dumped all my LOR boxes and bought all LE kits for 2017.  I am just now getting them running and I want to configure the light curves for all.  I have Windows 10 Pro 64 bit on my laptop.  I have installed the FTDI driver and I assume it is functioning because it did complete the install without any error messages.   I also installed the LE Config Utility.  I purchased a DMX Dongle V2.0 from another member and he assured me that it works. 

When I plugged in the dongle I received a "ding" from my computer but that was all I saw.  I checked the device manager and it does say USB Serial Device on COM 6.  So I guess that confirms my device is installed and working.  It appears these devices don't give any feedback to show they are installed.

Inside the Config Utility, I first went to Settings - Comport to try to update it.  I was doing this just to see if things are communicating. Then I get an ugly message saying an "Unhandled exception has occured."  And also says access to my Config.xml is denied !   It did show the correct path to my Config.xml.   I tried other com ports and got the same error.  It also tells me I can continue, but instead I have cancelled so I don't add more problems.  Is this to be expected?/  Should I just continue or am I already OK since device mgr shows USB Serial Device on COM 6?

I have the USB Dongle connected to the DMX IN of a V5 LE Express.  But the Data Link Light is not on.  I also tried to Update Light List from the DLA website and get immediate error.  Ugh ...  This one is frustrating.  Is there a way to can get the latest light list installed without going blind to the DLA website ?

Thanks in advance.  I hope some of you can get me pointed in the right direction.
« Last Edit: September 25, 2017, by kidcole »
Thanks,

Denny Cole
ChristmasCarolina.com

Offline kidcole

  • Full Member
  • ***
  • Posts: 71
  • Light Crazy Since 2009
Re: DMX Dongle V2.0 and LE Config Utility Install Issues
« Reply #1 on: September 25, 2017, »
I've made some progress.  It appears that the Config Utility is sending DMX data to the LE.  When I hit PROGRAM, the DMX Link led does flicker.  I also looked inside at the DMX Dongle board.  The green light it flickering.  So it does appear to be sending data.  But still no progress with the programming.  I've tried putting the LE into program mode (PRG, then Select to get the dot on the right) then starting the Config Program button.  But no results.  I won't change the start channel to a new number.  I also tried the reverse by starting the Config Tool first, then PRG .. Select.  Still no results.

I also tried resetting the LE, and also restarting the USB Dongle in the port. 

I finally got the LIGHT LIST to download.  I found a post from 2011 that gave instructions to modify UAC in Windows Control Panel .. THANKS to user mokeefe !

*****************************
It might be a User Account Control (UAC) issue.  You could try turning off UAC in Windows.  You can find the setting by going to Control Panel -> User Accounts -> Change User Account Control Setting.  In Win 7 they changed this setting to use a slider.  Slide it all the way down to "Never Notify".  This is sometimes necessary for legacy software to work correctly under Win 7

-Mike
******************************

Win 10 is the same way.  Fix UAC and the light list download worked.

Just to confirm, I am starting the config utility "Run as Administrator" and UAC is fixed.  The Dongle is sending data because the channels get all sorts of random DMX if I run the config utility without the LE being in program mode.  I tried selecting a new light curve on all the channels.  It still will not program my LE controller.
« Last Edit: September 25, 2017, by kidcole »
Thanks,

Denny Cole
ChristmasCarolina.com

Offline caretaker

  • Sr. Member
  • ****
  • Posts: 1750
Re: DMX Dongle V2.0 and LE Config Utility Install Issues
« Reply #2 on: September 25, 2017, »
First I have attached a file for RJ's DMX Deck which is a very simple program to communicate with the Lynx Express. Unzip and install the MSI file as Administrator then with your dongle connected to your LE try using the deck and see if the LED's (or plug in some lights) respond to the Deck. If they do then close the deck, open the config utility and set your start channel and light curves then put your LE in program mode (PGM) and press select so the dot appears on the display THEN hit the program bar on the config utility.  If you LE didn't respond with the DMX Deck you may need to reflash your LE.
From the wiki:
Programming the Express:
(At the Express...) Put your Express in program mode by pressing the "Mode" button until "PRG" appears on the LED display. Next, press the "Select" button -- a decimal point (dot) will appear on the right of the LED display to show "PRG." You are now in program mode.
(At the software configuration tool...) Select the "Program" button to send the channel configuration and light curve software to the Express. If you can observe the Express's LED display, you should note that the starting channel number now appears on the display. If it continues to show "PRG.", press the button again. It may take multiple attempts.
NOTE: you may choose to start the configuration tool first, and select the "Program" button within the tool -- then visit the Express within your yard to press the "Mode", then "Select" buttons. Either order will work.
(At the Express...) After the channel is assigned, reboot the Express by pressing the "Reset" button.
Debugging:
If the channel assignment is not taking...
verify that the USB DMX dongle is connected to the computer (the Green LED should be flashing while it sends configuration data)
verify that the Express is connected to the dongle (the Green "DATA LINK" LED should be flashing while the configuration tool sends data)
Jeff Squires
You are not allowed to view links. Register or Login

Offline kidcole

  • Full Member
  • ***
  • Posts: 71
  • Light Crazy Since 2009
Re: DMX Dongle V2.0 and LE Config Utility Install Issues
« Reply #3 on: September 25, 2017, »
Thanks Jeff.  I was not aware of the DMX Deck control panel.  I installed it and when it comes up, the DMX LINK LED on my LE starts flickering.  And the Deck does not change the channel settings on the LE.  I tried two more LEs with the same results.  I also tried changing the COM port on the Deck, with the same results.  Then I went back to the Config Utility and recognized that same flicker.

I opened the case of the Lynx DMX Dongle V2.  And without the dongle being connected to an LE, the green link LED on the dongle board started flickering when the Deck came up.  I am wondering if my DMX Dongle is the problem ?  I noticed there is a test jumper on the DMX dongle board.  But the assembly instructions do not provide any clues as to how to use the test function.
« Last Edit: September 25, 2017, by kidcole »
Thanks,

Denny Cole
ChristmasCarolina.com

Offline kidcole

  • Full Member
  • ***
  • Posts: 71
  • Light Crazy Since 2009
Re: DMX Dongle V2.0 and LE Config Utility Install Issues
« Reply #4 on: September 25, 2017, »
 When I read the "use" instructions for the USB DMX Dongle V2.0 it talked about pixelnet and sending out 4096 channels !   Could I be using the wrong device to program my LEs ?
Thanks,

Denny Cole
ChristmasCarolina.com

Offline KeithTarpley

  • Administrator
  • Sr. Member
  • *****
  • Posts: 1973
Re: DMX Dongle V2.0 and LE Config Utility Install Issues
« Reply #5 on: September 25, 2017, »
Greetings,,,

The test section of the dongle was set up in hardware for a possible future firmware update that never came about.

The dongle was originally for DMX.  It later had an option for pixelnet firmware to be used instead.  One or the other.  Here is the info for DMX:

You are not allowed to view links. Register or Login

Keith
"Now I know the only foe is time." -Moody Blues

Offline caretaker

  • Sr. Member
  • ****
  • Posts: 1750
Re: DMX Dongle V2.0 and LE Config Utility Install Issues
« Reply #6 on: September 26, 2017, »
To further what Kieth said the USB dongle can be flashed with either Pixelnet or DMX  IF the dongle is flashed with pixelnet it will not run a DMX device.
Jeff Squires
You are not allowed to view links. Register or Login

Offline kidcole

  • Full Member
  • ***
  • Posts: 71
  • Light Crazy Since 2009
Qui
« Reply #7 on: September 27, 2017, »
Thanks everyone.  I contacted the owner who sold me the DMX dongle and we're pretty sure it did have pixelnet firmware on it.  He had not used it in a long time and forgot.

 I'd rather shave my leg with a block plane than go down the path of the Pic programming.  Mostly because of all the seemingly unnatural acts to get them to work.  But against my better judgement, I went ahead with buying a Pic 3.  Ugh ..  I should have it by early next week.   I hope I can get it working, so I don't have to post back here for help.

 If anyone knows of updates to the documentation describing how to install and use a Pic 3, please let me know!  Quite often I find (here) that the original information is outdated.  But due to all the great help from the long timers, there are updates floating around.
Thanks,

Denny Cole
ChristmasCarolina.com

Offline caretaker

  • Sr. Member
  • ****
  • Posts: 1750
Re: DMX Dongle V2.0 and LE Config Utility Install Issues
« Reply #8 on: September 27, 2017, »
No worried Denny,  we will help you out, programming PIC's is not that hard.
Jeff Squires
You are not allowed to view links. Register or Login

Offline tbone321

  • Sr. Member
  • ****
  • Posts: 4011
Re: DMX Dongle V2.0 and LE Config Utility Install Issues
« Reply #9 on: October 02, 2017, »
It is a little harder with the Dongle as it doesn't have an ICSP header so the PIC needs to be removed from the dongle to be flashed.
If at first you don't succeed,
your not cut out for sky diving

Offline kidcole

  • Full Member
  • ***
  • Posts: 71
  • Light Crazy Since 2009
Re: DMX Dongle V2.0 and LE Config Utility Install Issues
« Reply #10 on: October 03, 2017, »
You are not allowed to view links. Register or Login
It is a little harder with the Dongle as it doesn't have an ICSP header so the PIC needs to be removed from the dongle to be flashed.

I received my PicKit 3 including the J1Sys board with the zif socket, for holding chips.  The same guy who sold me the V2.0 DMX adapter sent me the pickkit 3 setup and he also programmed the chip for the DMX dongle for me.

Three  boxes of pixels just arrived this morning from China, so I may not have time to play with the PicKit for a while.  I appreciate all the help here.  I'm glad you guys are still hanging out to keep the enthusiasts going !  I'll start a new topic if I need help with the flashing the LE pic chips.
Thanks,

Denny Cole
ChristmasCarolina.com