Author Topic: Access to the comm port denied  (Read 3531 times)

Offline LasVegasF250

  • Full Member
  • ***
  • Posts: 33
Access to the comm port denied
« on: March 25, 2011, »

Offline chrisatpsu

  • Sr. Member
  • ****
  • Posts: 3604
  • ahhh, yes... my new blink-i-nator 3000!!!
Re: Access to the comm port denied
« Reply #1 on: March 25, 2011, »
try temporarily turning off UAC (for windows Vista / 7) and try again. there are other methods, but you can check this rather quickly.

To rule the entire tri-state area!  What's that? Perry the Platypus!!!

Offline mokeefe

  • Sr. Member
  • ****
  • Posts: 508
Re: Access to the comm port denied
« Reply #2 on: March 25, 2011, »
You are not allowed to view links. Register or Login
try temporarily turning off UAC (for windows Vista / 7) and try again. there are other methods, but you can check this rather quickly.



He's running Win XP.  UAC didn't exist until Vista. That's not the issue.

-Mike

Offline chrisatpsu

  • Sr. Member
  • ****
  • Posts: 3604
  • ahhh, yes... my new blink-i-nator 3000!!!
Re: Access to the comm port denied
« Reply #3 on: March 25, 2011, »
control panel - > system -> hardware tab -> device manager

there should be an option to view by resourse type, look at IRQ, and see if the com port has the same IRQ as another device.
To rule the entire tri-state area!  What's that? Perry the Platypus!!!

Offline rm357

  • Sr. Member
  • ****
  • Posts: 1282
  • 31088
Re: Access to the comm port denied
« Reply #4 on: March 25, 2011, »
I think from your post, you did, but just to make sure, did you install the ftdi drivers?
(The windows drivers will not wok.)

Also, you may want to set it to a higher com port number. Com 1 through 4 have legacy hardware definitions that could cause a conflict with older hardware/chipsets. No likely, but possible.

RM
Robert
Warner Robins, Georgia, USA

Offline LasVegasF250

  • Full Member
  • ***
  • Posts: 33
Re: Access to the comm port denied
« Reply #5 on: March 25, 2011, »
I work with these driver for other devices I use on this computer. so when i plug it in it self installed the driver. The version of the FTDI driver is 2.8.2 and file version is 2.08.02 built by: WinDDk. What version is needed?

chrisatpsu: there is no resources tab to veiw the IRQ.

Offline LasVegasF250

  • Full Member
  • ***
  • Posts: 33
Re: Access to the comm port denied
« Reply #6 on: March 25, 2011, »
The current version on FDTI website is 2.08.12 and I see in the WIKI that we should be using 2.06 could this be the problem?

Offline chrisatpsu

  • Sr. Member
  • ****
  • Posts: 3604
  • ahhh, yes... my new blink-i-nator 3000!!!
Re: Access to the comm port denied
« Reply #7 on: March 25, 2011, »
menu, view, resources by type.
To rule the entire tri-state area!  What's that? Perry the Platypus!!!

Offline rrowan

  • Administrator
  • Sr. Member
  • *****
  • Posts: 5755
  • 08096
Re: Access to the comm port denied
« Reply #8 on: March 25, 2011, »
You are not allowed to view links. Register or Login
The current version on FDTI website is 2.08.12 and I see in the WIKI that we should be using 2.06 could this be the problem?

Sorry, any version from 2.06 and up will work just fine. Somebody has been lazy keeping the wiki up to date.

This really appears to be a Vixen issue. If Vixen thinks the com port is already in use it will give you this error. Also make sure you settings are correct in Vixen and the Add-ins menu make sure the DMX is not checked.  Can you give a screen shot of your settings?

Rick R.
Light Animation Hobby - Having fun and Learning at the same time. Some assembly Required

21st member of DLA

Warning SOME assembly required

Offline LasVegasF250

  • Full Member
  • ***
  • Posts: 33
Re: Access to the comm port denied
« Reply #9 on: March 25, 2011, »
Not sure if this was what you looking for.

Offline LasVegasF250

  • Full Member
  • ***
  • Posts: 33
Re: Access to the comm port denied
« Reply #10 on: March 25, 2011, »
You are not allowed to view links. Register or Login
menu, view, resources by type.

Here is the image of the resources.

Offline jnealand

  • Patron Member
  • Sr. Member
  • ****
  • Posts: 2304
Re: Access to the comm port denied
« Reply #11 on: March 25, 2011, »
After I get this error in the past I always exit vixen and reboot the computer.  Otherwise the first time I get the error seems the computer seems to tie up the com port until I do this and once it is tied up, marked as in use by Windows, no other operation will be able to access that port until it is release.  I reboot to force the release.  Also any time you modify and save a profile it works best if you exit vixen and then restart it.
Jim Nealand
Kennesaw, GA

Offline LasVegasF250

  • Full Member
  • ***
  • Posts: 33
Re: Access to the comm port denied
« Reply #12 on: March 25, 2011, »
Well it appears the problem is in my PC. Loaded Vixen and Dongle on a different PC and attache the LE to the Dongle and everything worked great. Thanks for all the responds. If I figure out the problem on the PC I will update this thread. Again thanks to everyone. BTW this was my first build on both the Dongle and LE.

Offline dmaccole

  • Patron Member
  • Sr. Member
  • ****
  • Posts: 736
    • PacificaLights.info
Re: Access to the comm port denied
« Reply #13 on: March 25, 2011, »
You are not allowed to view links. Register or Login
Well it appears the problem is in my PC.

On more than one occasion I have found that deleting the Vixen folder and unzipping a new one has saved my "com port denied" bacon.

\dmc
________________________
The only thing more dangerous than a software engineer with a soldering iron or a hardware engineer with a compiler is a liberal-arts major with either.
You are not allowed to view links. Register or Login

Offline rrowan

  • Administrator
  • Sr. Member
  • *****
  • Posts: 5755
  • 08096
Re: Access to the comm port denied
« Reply #14 on: March 25, 2011, »
Congrats on the first build of the dongle and LE

Have fun with blinky flashly

Cheers

Rick R.
Light Animation Hobby - Having fun and Learning at the same time. Some assembly Required

21st member of DLA

Warning SOME assembly required